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Creating Accessible PDFs Using  
Adobe InDesign CS3 & Adobe Acrobat 9

This manual was developed as a joint project of the Disability Programs and Resource Center 

(DPRC) and ACCESS, the CSU Accessibility Initiative at San Francisco State University. It 

was designed by Angela Dowd and supervised by Nora Scully, Accessible Technology Train-

ing Consultant at DPRC. This manual is a guide for designers and instructors to use when 

working independently, creating accessible PDFs from InDesign CS3 files. We developed an 

online tutorial to walk you through the steps of this process. We are providing this manual, 

that is aligned with the steps of the tutorial, to help with transferring some of the skills you 

have learned to your own work.

http://www.sfsu.edu/~dprc/
http://www.sfsu.edu/access/
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Filling Out Document Information

When creating an accessible document, the first thing to do is fill out your document description. 
Select File > File Info > Description and put in all of the information you want to identify your file.

TIP: File Information can  be saved and exported to different documents. You can put in meta-
data to provide information on the accessibility features of  a particular resource. Metadata also 
improves search engine optimization.
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Identifying the Workspace: Working with the Structure Pane

1.	Study the InDesign Structure Icons that are included in the Appendix of this document.		
	 InDesign’s structure icons are very similar to XML tags. They are used to define the 			
	 semantic structure of the document.

2.	Select  View > Structure > Show Structure to open the Structure Pane.

3.	Click on the arrow to the left of the Root Element symbol < >

The Root Element is always the first icon in the Structure Pane. The Structure Pane displays the 
semantic structure of  your document.
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Identifying the Workspace: Working with the Structure Pane

4.	Select  View > Structure  > Show Tagged Frames.

5.	Select View > Structure > Show Tagged Markers.

TIP: You will not be able to see tagged items if  either Show Tagged Frames or Show Tagged 
Markers is not turned on. Show Tagged Markers is helpful to turn on to see your tags. If  an item is 
not tagged it will not be read by a screen reader.
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Identifying the Workspace: Working with the Structure Pane

6.	 In the top right corner of the Structure Pane, click on the fly-out menu arrow.

7.	Scroll down and select Hide Text Snippets and then Show Text Snippets.

TIP: Text Snippets help identify the contents of  each element. This becomes very important when 
you must move tags that are out of  place.
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Identifying the Workspace: Working with the Tags Panel	

•	 Select Window > Tags to access the Tags Panel.

When you select a tagged item in your document it is underlined in the Structure Pane and the tag 

is highlighted in the Tags Panel.
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Applying Alternative Text: Inserting Anchored Objects

1.	Place the text curser in the location you want your image to be inserted.

2.	Select Objects > Anchored Objects > Insert.

3.	Select Graphic for Content and Basic Graphics Frame for Object Style in the drop 		
	 down menu. You can also create your own customized Object Style.

4.	Select File > Place to place your linked image (from the images folder within project).

TIP: Once your image is anchored it can be tagged and will remain in place if  any changes in 
the copy are made. Images must stay in place so their context will be correct. Otherwise screen 
readers will read them incorrectly. Be sure your image files are linked and not embedded.



CSU   Accessible   T echnology Initiative   at SF State 

Creating Accessible PDFs Using Adobe InDesign CS3 & Adobe Acrobat 9

Page 7

Applying Alternative Text: Assigning Attributes

5.	Tag your images (Refer to page 13 to tag all images automatically with the Figure Tag).

6.	When you select a tagged image, the Figure Icon for that image will be underlined in the 		
	 Structure Pane.

7.	 In the Structure Pane, right click the highlighted underlined Figure Icon.

8.	Select New Attribute.

9.	Type Alt in the Name area and your Description (Alt Tag) in the Values area.
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Applying Styles: Using Paragraph Styles.

1.	Select Type > Paragraph Styles to access the Paragraph Styles Panel.

2.	 In the Paragraph Styles Panel, click the fly-out menu at the top right to open the 
	 Paragraph Style Options box.

3.	 In the menu to the left, click on Indents and Spacing.

4.	Specify paragraph spacing by entering amounts in Space After and/or Space Before.

TIP: Name your styles using the Heading “H”, Paragraph “P”, List “L” to simplify the tagging 
process. They are standard Adobe element tag names. Please see Appendix for more clarification.
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Tagging Page Numbers: Styling and Overriding Master Page Items 

1.	Locate and open your Master Page by selecting A-Master. 

2.	 Insert and style your Special Character Marker for your page numbering.

3.	Leave the Master Page and return to your document pages. 

4.	Using your selection arrow, Command Shift Click on each page number to Override 		
	 these specific Master Page Items. You will later tag each page number.

NOTE: Master Page Items show up on every page. They are dotted around the edges. It is recom-
mended that Master Page Items NOT be tagged. A Master Page Item will only read out one time. 
Page numbers have to be tagged separately and relocated in the Structure Panel.



CSU   Accessible   T echnology Initiative   at SF State 

Creating Accessible PDFs Using Adobe InDesign CS3 & Adobe Acrobat 9

Page 10

Creating Hyper Links: Displaying the Hyperlinks Panel

1.	Select  Window > Interactive > Hyperlinks to display the Hyperlinks Panel.
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Creating Hyper Links: Accessing the Hyperlinks Options Box

2.	Choose a name with descriptive text for your URL.

3.	Select the name and/or URL you want to create a hyper link to.

4.	Select New Hyperlink in the Hyperlinks Panel fly-out menu at the top right to access 		
	 the Hyperlink Options Box. 

Using a descriptive name makes the link more accessible. The name should identify the target 
so the user will know the exact location they are being taken to. Click Here does not identify the 
target. Labeling links appropriately also adds context when a screen reader is reading links out.
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Creating Hyperlinks: Filling in the Hyperlink Options Box

5.	For Destination/Name, type the name of the hyperlink. The name you type will appear 		
	 in the Hyperlinks Panel. 

6.	For Destination/Type, select Page, Text Anchor, or URL and choose destinations.

7.	For Appearance/Type, select Visible Rectangle. This will create a box around the link.

8.	For Appearance/Highlight, select None. 

If  you choose Invisible Rectangle, create an underlined paragraph style to make text look like a link.
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Adding Tags: Add Untagged Items Automatically

•	 Select Structure Pane > Structure Options > Add Untagged Items.
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Adding Tags: Mapping Styles to Tags Automatically

1.	Go to Window > Tags.

2.	Click on the Options Arrow in the upper right of the Tags Panel.

3.	Select Map Styles to Tags.
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Adding Tags: Mapping Styles to Tags Automatically

4.	 In the diagram below, use the Pop-up Menu in the right column to assign Tags to Styles. 

5.	Notice that each Tag is assigned a Style.

You can use both automatic and manual tagging. Automatic tagging is good to use because it 
saves time. Using the Adding Untagged Items option applies the Story Tag to everything in the 
document (if  it is contained within the threaded text box). It also tags images with the Figure Tag. 
If  items are not tagged, they will not read out loud in a screen reader. This is a way to assure that 
your content gets tagged. You can remove tags, change tags and add additional tags later.
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Adding Tags: Manual Tagging

1.	Select View > Structure > Show Tagged Frames to see if everything is tagged.

2.	Check to be sure Icons in the Structure Pane and Tags in the Tags Panel match.

3.	Tag text manually by selecting the item and choosing the correct tag from Tags Panel.
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Exporting InDesign File to PDF format: 

1.	Select File > Export > Adobe PDF and check appropriate boxes.

2.	Choose compatibility and print quality based on the printing facilities available.

	
Note: Remember that you must check off  Bookmarks, Hyper links, and Interactive Elements to 

make them available in your PDF.
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Working with the PDF in Acrobat: Setting the Document Language

•	 Select File > Properties > Advanced > Drop down Menu > Choose Language

TIP: You must assign a language for the document to be accessible.
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Working with the PDF in Acrobat: Check the Page Properties Dialog Box

•	 Go to View > Navigation Panels > Pages and select all pages in document.

•	 Right click and choose Page Properties.

•	 In Tab Order choose Use Document Structure and click OK.
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Working with the PDF in Acrobat: Check the Tabbing Order

•	 Select View > Navigation Panels > Order to view reading order

TIP: You will see your content grayed out with numbers indicating the reading order for each page. 
To correct the order you will have to open your Tags Panel Options and access the Touch Up 
Properties Dialog Box. If  you find a number with an empty grayed box it means you have an empty 
tag that should be deleted.
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Working with the PDF in Acrobat: Setting up Linking Bookmarks

1.	Select Bookmark Options (at the top left corner) > New Bookmarks from Structure

2.	Choose Headings and Subheadings (these are the items you will want to bookmark).

Creating a semantic structure from the start with Paragraph Styles and Tags creates anchor links 
for your bookmarks. These links take readers to the headings and subheadings you specified 
previously in your hierarchy.



CSU   Accessible   T echnology Initiative   at SF State 

Creating Accessible PDFs Using Adobe InDesign CS3 & Adobe Acrobat 9

Page 22

Working with the PDF in Acrobat: Checking Details

•	 Select View > Navigation Panels > Tags

You can work with tags in Acrobat, but it is best to do as much as possible in InDesign. You cannot 

undo mistakes when using Acrobat. InDesign allows you to edit tags if  your document is revised.
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Accessibility Full-Check (from the Acrobat Help Pages)	

Select Advanced > Accessibility > Full Check 
For the Section 508 and W3C guidelines, the options area includes a Browse button that links to 
the website for the respective guidelines.

Select Adobe PDF to choose from options for the Adobe PDF accessibility standard:

•	 Alternative Descriptions Are Provided:
	 Checks for tagged figures that are missing alternate text.

•	 Text Language Is Specified: 
	 Checks for paragraphs that don’t have a language specified for them. Setting the 
	 language for an entire document in the Document Properties dialog box corrects all  
	 errors related to this option.

•	 Reliable Character Encoding Is Provided:
	 Checks for fonts that are inaccessible to screen readers and other assistive software. 		
	 Fonts must contain enough information for Acrobat to correctly extract all the characters 		
	 to text. If one or more fonts don’t allow for the correct extraction of all the characters, the 		
	 PDF is inaccessible.

•	 All Content Is Contained In The Document Structure:
	 Checks for page elements that have been overlooked during tagging. Adding these 
	 elements to the tag tree (if necessary) ensures that a screen reader can present the  
	 content to a user.
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Accessibility Full-Check (continued)	

•	 All Form Fields Have Descriptions:
	 Checks for form fields that are missing descriptions.

•	 Tab Order Is Consistent With The Structure Order:
	 Checks whether tags properly reflect the document structure. 

•	 List And Table Structure Is Correct:
	 Checks whether tags that have been generated for lists and tables meet the requirements 		
	 of tagged PDF.



Appendix: Structure Pane Icons from Adobe InDesign CS3 Help Pages

http://livedocs.adobe.com/en_US/InDesign/5.0/

