Creating Accessible PDFs Using
Adobe InDesign CS3 & Adobe Acrobat

This tutorial is being provided in two fomats— a printed file for you to follow along with
and a digital file for you to practice using. We would like to introduce you to some of the
ways that you can create accessible documents when designing instruction. InDesign
creates tagged documents. These documents can be exported as tagged PDFs.
InDesign files can be made into templates and re-used.

In this tutorial, we will show you how to:

Add a Document Description that includes accessible file Information.

» Use the InDesign Structure Pane to make your document’s Semantic Structure
accessible

» Use the Tags Panel to tag both words and images to be read by screen readers.
* Insert images as Anchored Objects, keeping images and text in context.
* Apply Alternative Text to Images to add meaning for visually impaired learners.

» Use Paragraph Styles that can be mapped to tags and styled to improve
accessibility.

» Create Page Numbers that will be read by a screen reader.

» Create and style Hyperlinks so they will be noticeable and accessible.

» Export an InDesign to PDF format.

» Set the Document Language in Adobe Acrobat 9 to make the PDF accessible.
» Check the Tabbing Order in Acrobat 9 to checking the reading order.

* Listen to your document using Acrobat’s Read Out Loud feature.

» Create Bookmarks which can be used when making a Table of Contents.

+ Complete an Accessibility Full-Check of the document’s accessibility.
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Document Description

FiLLing our DoOCUMENT INFORMATION

Let’s Practice

* Open the “pdf_tutorial” Document in the ACCESS folder on your desktop.

» Select “File” > “File Info” > “Description”. Fill in description and save the file adding
an underscore “_" and your initials.
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TIP: File Information can be saved and exported to different docu-
ments. If you are using the same information, it is very helpful

to have this filled out . You can also put in metadata to help with
search engines.



|dentifying the Work Space

WoRKING WITH THE STRUCTURE PANE

+ Study the “Structure Pane” Handout of Adobe InDesign icons.

» Select “View” > “Structure” to open the “Structure Pane”
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Let’s Practice

* Click on arrow to the left of the the “Root” < > Symbol in your document.

Select “View” > “Structure” > “Show Tagged Frames”

Select “View” > “Structure” > “Hide Tagged Frames”

Select “View” > “Structure” > “Show Tag Markers”

The Structure Pane shows the semantic structure of your document.

TIP: You will not be able to see tagged items if either “Show Tagged
Frames” or “Show Tagged Markers” is not turned on. “Show
Tagged Markers” is helpful to turn on to see your tags. If an item is
not tagged it will not be read by a screen reader.



WoRKING WITH THE STRUCTURE PANE
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* In the top right corner of the Structure Pane, click on the fly-out menu arrow.
 Scroll down and select “Hide Text Snippets”

» Select “Show Text Snippets”

TIP: Text Snippets help identify the contents of each element. This
becomes very important when you must move tags that are out of
place.



WoRrkiING WiTH THE TAGs PANEL
+ Select “Window” > “Tags” to access “Tags Panel”
* Notice the tags that have been created.
B Fie E® Lavor Type Notes Cbect Table e L] Heb
L W ) it I acam AR
s Wi Hi = # U 1"'-1'1'“ I
¢ @ o 3 [seom]es Aasirantris Eicwsen =
- [T me
L = Fustomston
13 A 7] Codr L
o (Rl S “Crbwting Sorensble Cicunees b, ] w Cookrol [N Y Dfzetar
B H SCreariog Aucestbie Doosmte” - Effects e+ QrkFLO O
B HL Mk Wond 2007 iSradberk Ot
B e Pobboen G | | E:mm & , | e
B P Pobbshed March, Copyright 20080 : Lapers g -
= e ] Links sft+crhe | O
B P "hean wels Eduee” Motes [ L3
B i “webdcabiae ehi® et B Lapout v | O
- [@e r Obgect Srles cHET | @
B P “leale Mg Conters Edog” =] | ] :::': ELz ' Oua
B ek Srsndnfoaeds” . Shroke o | W -
= [Je ] Swsbches pr | O
LR T | - LU
Let’s Practice
+ Select image below using the selection arrow.
* It has been tagged with a “Figure” tag.
» Tagged images are underlined in the In “Structure Pane”
* When selected they are also highlighted in the “Tags Panel”
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Applying Alternative (Alt) Text

INSERTING ANCHORED OBJECTS

* Place the text curser in the location you want your image to be inserted.
» Select “Objects” > “Anchored Objects” > “Insert”.

» Select “Graphic” for “Content” and “Basic Graphics Frame” for “Style”.
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Let's Practice

* Locate the “images” folder inside of the “ACCESS” folder on your desktop.
+ Using the selection arrow, click on the box below to select it.
+ Select “File” > “Place” > Images folder > “CSU.gif” to link your images.

+ Right Click and scroll down to “Fitting” > “Fit Frame to Content”.




m The California State University

WORKEING FOR TALIFORMNIA

* Your anchored object should look just like the one you see above.
+ Select the above CSU image with the selection arrow.

« Click on the “Figure” tag in the “Tags Panel” to tag it as a “Figure”
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* Notice that it is underlined in the “Structure Pane”.
» Select the CSU image again using the selection arrow.

* In the “Structure Pane”, right click the highlighted, underlined “Figure” icon.
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» Select “New Attribute” from the New Attributes panel.

» Type “Alt” in the “Name area and your description in the “Values” area. Click OK.



Applying Styles

» Select “Type” > “Paragraph Styles” to access the Paragraph Styles Panel.

TIP: Notice that the styles in this document are named using
Heading “H”, Paragraph “P”, List “UL” elements. Using standard
Adobe element tag names in paragraph styles simplifies tagging.

Let’s Practice

 Select the three words below and style them using the “H” Style in the Paragraph
Styles Panel.

Using Paragraph Styles
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before and after. Do not use paragraph returns

Double click the “P” Paragraph Style to see the style “Options”.

* In the menu to the left, double click on “Indents and Spacing”.

Look at the ways before and after paragraph spacing is used in this style.

Notice the Semantic Structure that has been set up in the Paragraph Styles.

Note: Paragraph styles is the recommended way to leave extra
spaces after lines. Returns create unnecessary tags that you later
have to delete.



Tagging Page Numbers

OVERRIDING MASTER PAGE ITEMS
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Let’s Practice

» Go to the bottom left corner (page number area) and hold down the arrow to
select A-Master

* Notice the page marker that says Page A.
+ Select this marker text on the Master Page and apply a “P” paragraph style to it.

» Leave the Master Page. Go to each page in the document. Select each page
number while hitting “Command” > “Shift” > “Click” or “Control” > “Shift” > “Click”

+ Later you will tag each page number.
* When tagged, each page number will appear in the bottom of the “Structure Pane”

* You will have to drag it to the correct location by looking at the “Snippets”

TIP: Master Page Items can be tagged but will only read out one
time. It is recommended that page number markers on Master
Pages not be tagged.
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Creating Hyperlinks

* Choose “Window” > “Interactive” > “Hyperlinks” to display the “Hyperlinks Panel”

+ Select your url.
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* Choose “New Hyperlink” in the Hyperlinks Panel fly-out menu at the top right to
access the “Hyperlink Options” Box.

Create a hyperlink for San Francisco State University.
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Name: San Francisco State University C ok )

— Destination ( Cancel I

Document: | INDesign_tutorial.indd |
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Let’s Practice

* For Name, type the name of the hyperlink. The name you type will appear in
the Hyperlinks panel.

» For Type, select Page, Text Anchor, or URL to display the available
destinations for that category. To display all destinations, select All Types.

To specify the appearance of a hyperlink in InDesign and in the exported PDF
file, do the following, and then click OK:

» For Appearance Type, select Invisible Rectangle.

For Highlight, select None.

For Style, select “Link” in the document Paragraph Styles Panel.

Create a hyperlink for San Francisco State University using the url below.

http://www.sfsu.ed


http://www.sfsu.edu

Adding Tags

ADD UNTAGGED ITEMS

Let's Practice

* Choose “Window” > “Tags” to access “Tags Panel”

» Select “View” > “Structure” > “Show Tagged Markers”
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+ Select “Add Untagged Items”

» This will add a “Story” tag to each frame and the “Image” tag to each image.



Adding Tags

MarP STYLES TO TAGS

* Go to Window > Tags
* Click on the Options arrow in the upper right of the “Tags” Pane.

» Select “Map Styles to Tags”
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* In the diagram below, the pop-up menu in the right column is used to assign Tags
to Styles.

* Notice that each Tag is assigned a Style.
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Export to PDF

PDF ExPORT SETTINGS

» Select “File” > “Export” > “Adobe PDF” and check appropriate boxes.
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Check Optimize for Fast Web View.

» Choose compatibility and print quality based on who the learners are.

Create Tagged PDF.

View PDF after exporting.

Bookmarks.

Hyperlinks.

Interactive Elements



Working with your PDF in Adobe Acrobat 9

SET THE DoCcUMENT LANGUAGE

* Open your document in Adobe Acrobat 9

» Select “File” > “Properties” > “Advanced” > “Dropdown Menu” > “Choose
Language”
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TIP: You must assign a language for the document to be
accessible.



Check the Tabbing Order

» Go to “View” > “Navigation Panels” > “Pages” and select all pages in document.
* Right click and choose “Page Properties”

* In “Tab Order” choose “Use Document Structure” and click OK.

[1 prking with PDF in Adobe Acrobat 8 |
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TIP: You will see your content grayed out with numbers indicating
the reading order for each page. To correct the order you will have
to open your “Tags” Pane “Options” and access the Touch Up
Properties Dialog Box. If you find a number with an empty grayed
box it means you have an empty tag that should be deleted.



Read Out Loud

» Select View > Read Out Loud > Activate Read Out Loud to listen to the way your
document sounds.

Create Bookmarks
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» Select Bookmark lcon > “New Bookmarks from Structure”.

 This is why we create a Semantic Structure from the start using Paragraph Styles
and Tags.

 This will creates anchor links for your bookmarks to take readers to the headings
and subheadings you specify in your hierarchy.
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Accessibllity Full-Check

» Select “Advanced” > “Accessibility” > “Full Check”

For the Section 508 and W3C guidelines, the options area includes a Browse button
that links to the website for the respective guidelines.

Select Adobe PDF to choose from options for the Adobe PDF accessibility standard:

Alternative Descriptions Are Provided Checks for tagged figures that are missing alter-
nate text.

Text Language Is Specified Checks for paragraphs that don’t have a language speci-
fied for them. Setting the language for an entire document in the Document Properties
dialog box corrects all errors related to this option.

Reliable Character Encoding Is Provided Checks for fonts that are inaccessible to
screen readers and other assistive software. Fonts must contain enough information for
Acrobat to correctly extract all the characters to text. If one or more fonts don’t allow for
the correct extraction of all the characters, the PDF is inaccessible.

All Content Is Contained In The Document Structure Checks for page elements that
have been overlooked during tagging. Adding these elements to the tag tree (if neces-
sary) ensures that a screen reader can present the content to a user.

All Form Fields Have Descriptions Checks for form fields that are missing descriptions.

Tab Order Is Consistent With The Structure Order Checks whether tags properly reflect
the document structure.

List And Table Structure Is Correct Checks whether tags that have been generated for
lists and tables meet the requirements of tagged PDF.
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